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CalendarPublisher for DayliteCalendarPublisher for Daylite
About CalendarPublisherAbout CalendarPublisher
With CalendarPublisher it is possible to publish and share Daylite appointments read-only with
external persons.

This is being facilitated by exporting Daylite appointments either manually or automatically as
ICS files. You can determine which appointments are being exported by creating calendar smart
lists, the export time interval, the desired location of the exported ICS file or whether the
appointment title shall be replaced by a placeholder.

Depending on the scenario, it is recommended to save the ICS file to a FTP server, a WebDAV
share or your Dropbox' public folder. Externals can then add the shared ICS file to their
calendar.

Alternatively it is possible to transfer the ICS file into a HTML calendar by using a service like
Google for instance and integrate it into you website.

FeaturesFeatures
CalendarPublisher features the following functions:

• Export of appointments (from preset calendar smart lists) as an ICS file
• Configurable export intervals
• Configurable storage location of the exported ICS file (FTP, WebDAV, Dropbox, etc)
• Configure whether the actual appointment title or a placeholder is being used when

publishing the calendar
• Read-only access to published appointments for externals

System RequirementsSystem Requirements
Operating System: OS X 10.8 or newer

Daylite Version: 4.3 or newer
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SetupSetup
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InstallationInstallation
1. 1. To check your Daylite version, go to the Daylite menu and select 'About Daylite'About Daylite'.
CalendarPublisher requires at least Daylite 4.3.

2. To check your OS X version, go to the Applethe Apple menu and select 'About this Mac''About this Mac'.
CalendarPublisher requires at least OS X 10.8.

3. Download CalendarPublisherCalendarPublisher. Double-click CalendarPublisher for Daylite.dmgCalendarPublisher for Daylite.dmg

4. Double-click ''CalendarPublisherCalendarPublisher.daylite-plugin'.daylite-plugin'.
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5. Click install

6. To finalize the installation click 'Restart Daylite'
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After the installation CalendarPublisher can be used for 14 days free of charge. If you would like
to use it after these 14 days, please proceed to chapter 'Licensing'.
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LicensingLicensing

After the installation it is possible to test CalendarPublisher during a 14 day trial period. If
you woud like to continue using the plug-in, you need to purchase a license. In order to
purchase CalendarPublisher, please follow these steps (given the plugin is already
installed):

1. Start Daylite

2. In the Daylite menu select Plugins --> CalendarPublisher --> Preferences...Plugins --> CalendarPublisher --> Preferences...

3. Select the LicenseLicense tab and click Purchase CalendarPublisher...Purchase CalendarPublisher...

4. Select whether you would like to subscribe to CalendarPublisherCalendarPublisher as a monthly service or to
purchase it at a single payment.
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CalendarPublisher SubscriptionCalendarPublisher Subscription
If you would like to subscribe to the CalendarPublisherCalendarPublisher , please do the following:

1. Click on the button at a monthly all-inclusive rateat a monthly all-inclusive rate and then on NextNext

After completing all steps you'll see this window
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Purchase CalendarPublisherPurchase CalendarPublisher
If you would like to purchase CalendarPublisherCalendarPublisher, please do the following:

1. Click on the button at a single paymentat a single payment and then on NextNext

After completing all steps you'll see this window
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UsageUsage
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Daylite Calendar Smart ListsDaylite Calendar Smart Lists

In order to publish Daylite your need to create a calendar smart list to filter the desired
appointments first.

Create Smart ListCreate Smart List
1. To filter specific appointments, determine whether you would like to filter your own

appointments or appointments owned by other Daylite users:

• If you want to publish your own appointments select My CalendarMy Calendar from the Daylite
sidebar

• If would like to publish your colleagues's appointments select Users & RessourcesUsers & Ressources from
the Daylite sidebar

2. Click the magnifying glas symbol right next to cog wheel
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3. Select the desired filter criteria

4. Save smart list

Example: Smart List to Filter for Own AppointmentsExample: Smart List to Filter for Own Appointments
In our first example we want to publish all appointments by the category ConsultingConsulting that take
place this year.

To filter for those appointments, follow these steps:

1. Select the category ConsultingConsulting
2. Select the Start DateStart Date criteria and the options isis & this yearthis year
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3. Click Save as Smart ListSave as Smart List and assign a name
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Example: Smart List to Filter for Other Daylite Users'Example: Smart List to Filter for Other Daylite Users'
AppointmentsAppointments
In our second example we want to create a smart list that filters all Daylite user's appointments
by the category Seminar that start next year.

To create this smart list, follow these steps:

1. Click UsersUsers & Resource& Resourcess
2. Click the user drop-down menu and select AllAll
3. Click the magnifying glas
4. Select the category SeminarSeminar
5. Select the Start DateStart Date criteria and the options isis & next yearnext year

6. Click Save as Smart ListSave as Smart List and assign a name
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PreferencesPreferences
PreferencesPreferences
The Daylite appointments are aways being exported based on preset Daylite calendar smart
lists.

Follow this steps to configurate the Plug-in:

1. Start Daylite

2. In the Daylite menu navigate to Plugins -> CalendarPublisher -> Preferences.Plugins -> CalendarPublisher -> Preferences.

1. Click the plus sign to create a new calendar export and determine a name.
2. Select the list you want to publish from the Smart ListSmart List drop-down menu.
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Select Storage LocationSelect Storage Location

CalenderPublisher supports several options to publish your calendar:

1. Local
2. FTP
3. Dropbox

LocalLocal

Local:Local:

When selecting LocalLocal you can have your calendar being exported to an arbitrary folder. This
could be either a specific local folder, a network share or a mounted folder on a WebDAV
server.

FTPFTP

FTP:FTP:

Select FTPFTP if you want to publish your calendar via a FTP server.

Please note:Please note: before you pass on the link to the exported ICS file to a subscriber, you need to
replace ftp://ftp:// with http://http://
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DropboxDropbox

Dropbox:Dropbox:

The Dropbox service enables you to share your calendar without a FTP server.
CalendarPublisher automatically detects the public folder of your Dropbox (if Dropbox has
been installed to the default location) and saves the exported calendar file and all updates
there.

If you have used an alternative path for you Dropbox folder, please select LocalLocal instead of
DropboxDropbox from the drop-down menu and manually select your Dropbox public folder.

Please note:Please note: Dropbox has limited the usage of the public folder and is only available if:

• Your dropbox account has been created before 4 October 2012
• Your using a paid Pro or Business account

If you meet the above requirements but the public folder is not available, please follow this link
to activate it.

If you're using a free Dropbox account that has been created after 4 October 2012, there is no
other way other than upgrade to a paid Dropbox Pro or Business to restore the public folder
functionality.

If you would like to share the link to your exported calendar without a public Dropbox folder,
advanced users can do so by editing the Dropbox link as described below.

Edit the link you receive by clicking "Share Dropbox link" as follows:
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ChangeChange https://www.dropbox.com/xxxxxx/Dateiname.pdf?dl=0 Â toto
Â https://www.dropbox.com/xxxxxx/Dateiname.pdf?dl=1

The link can now be used as described in this manual.

Anonymize all calendar eventsAnonymize all calendar events

Determine whether the actual appointment titles shall be replaced by the preset text
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Use individual time frameUse individual time frame

Determine the timeframe of appointments you want to publish. If you would like to keep your
published appointments up-to-date, you need to select the option to adjust the timeframe
dynamically. This advances the publishing timeframe dynamically by one day increments.
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Use CasesUse Cases

The following describes different scenarios how to use CalendarPublisher.

Example:Example: Share via DropboxShare via Dropbox
Select DropboxDropbox and configure the publishing preferences as desired and described here.

Send the Calendar File LinkSend the Calendar File Link

To enable an external person to subscribe to an published calendar, you need to send this
person a link to the exported calendar file.

To do so, please follow these steps:

1. Copy the public link to the ICS file by right-clicking the file and selecting Copy Public LinkCopy Public Link
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2. Send the link via email or put it on your website.

When the recipient clicks the link, this person's calendar app associated with the .ics file format
should open and offer to subscribe to the calendar

Alternative Subscription in Apple CalendarAlternative Subscription in Apple Calendar

To subscribe to the calendar directly in Apple Calendar, the recipient needs to follow these
steps (the steps should be similar in other calendar apps):

1. Open Apple Calendar
2. In the Apple Calendar menu navigate to File -> New Calendar SubscriptionFile -> New Calendar Subscription

Page 25Page 25CalendarPublisher for Daylite



3. Paste the provided link and click SubscribeSubscribe

Example:Example: HTML CalendarsHTML Calendars
To integrate the exported calendar as a HTML calendar on your website, you need to convert
the ICS file into an HTML calendar. One way to achieve this is to use a Google calendar. Google
calendar provides the option to subscribe to a ICS calendar and to subsequently make it
available as HTML calendar.

Please note: according to Google it may take up to 8 hoursPlease note: according to Google it may take up to 8 hours before a change in a subscribed ICSbefore a change in a subscribed ICS
feed shows in Google calendarfeed shows in Google calendar..
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Save Calendar FileSave Calendar File

Starting point is always the link to the exported ICS file as described above

Subscribe to Calendar in GoogleSubscribe to Calendar in Google

1. Log on to your Google account

2. Click Other calendarsOther calendars -> Add by URL-> Add by URL and paste the link to subscribe to the exported Daylite
calendar
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Setup HTML CalendarSetup HTML Calendar

To integrate your calendar in your website, proceed as follows:

Under Other calendarsOther calendars you'll find your calendar. Click the little arrow next to it and select
Calendar settingsCalendar settings

Page 28Page 28CalendarPublisher for Daylite



HTML Code of YourHTML Code of Your CalendarCalendar

The required HTML code is being displayed as shown in the screen shot below. Copy the code
and integrate it in your website
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MiscellaneousMiscellaneous
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Removing the Plug-inRemoving the Plug-in

Follow these steps to deinstall a Daylite plugin

1. Open FinderFinder

2. In the menu bar select GoGo and hold down the ⌥ alt keyalt key. The LibraryLibrary folder will appear.
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4. Navigate to the folder Application SupportApplication Support ->

5. -> com.marketcircle.Daylite4com.marketcircle.Daylite4 ->
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6. -> PluginsPlugins

7. Delete the file CalendarPublisher.daylite-pluginCalendarPublisher.daylite-plugin
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8. Restart Daylite
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